summaryrefslogtreecommitdiff
path: root/heap/ebus-web-python/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'heap/ebus-web-python/setup.py')
-rw-r--r--heap/ebus-web-python/setup.py35
1 files changed, 35 insertions, 0 deletions
diff --git a/heap/ebus-web-python/setup.py b/heap/ebus-web-python/setup.py
new file mode 100644
index 0000000..e755919
--- /dev/null
+++ b/heap/ebus-web-python/setup.py
@@ -0,0 +1,35 @@
+#!/usr/bin/env python
+import subprocess
+from setuptools import setup, find_packages
+
+
+version = subprocess.Popen(["git", "describe", "--tags", "--long"],stdout=subprocess.PIPE).communicate()[0].strip()
+assert len(version) > 3
+
+
+setup(
+ name='ebus',
+ version=version,
+ description='Ebus Library',
+ author='xapek.org',
+ author_email='ebus@xapek.org',
+ url='http://xapek.org',
+ scripts=[
+ "ebus_web.py",
+ ],
+ packages=find_packages(),
+ package_data={'doc':['*.txt'], 'xml':['*.xml']},
+ include_package_data = True,
+ long_description="""ebus library""",
+ classifiers=[
+ "Programming Language :: Python",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ "Intended Audience :: Developers",
+ ],
+ requires=[
+ "bottle",
+ "SQLAlchemy",
+ "psycopg2",
+ ],
+ )
+