summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authoryvesf <yvesf-git@xapek.org>2011-07-24 13:12:14 +0200
committeryvesf <yvesf-git@xapek.org>2011-07-24 13:12:14 +0200
commit02f48f7a905973428fc7766cf92bb04614e1fdca (patch)
treed80aa26d4fec9b293ae135c29b10fc071df8ef71 /setup.py
parent75017423563a18986aa096566d8a2969c32c3588 (diff)
downloadebus-alt-02f48f7a905973428fc7766cf92bb04614e1fdca.tar.gz
ebus-alt-02f48f7a905973428fc7766cf92bb04614e1fdca.zip
cleanup, tag version 0.3v0.3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py25
1 files changed, 11 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index 4a3e284..aa607ed 100644
--- a/setup.py
+++ b/setup.py
@@ -1,16 +1,11 @@
#!/usr/bin/env python
+import subprocess
+from setuptools import setup, find_packages
-version='0.2'
-try:
- import pysvn
- from pysvn import Client
- import os
- extra = Client().info(os.path.dirname(__file__)).revision.number
- version = "%s-r%s" % (version,extra)
-except:
- pass
-from setuptools import setup, find_packages
+version = subprocess.Popen(["git", "describe", "--tags", "--long"],stdout=subprocess.PIPE).communicate()[0].strip()
+assert len(version) > 3
+
setup(
name='ebus',
@@ -20,9 +15,10 @@ setup(
author_email='ebus@xapek.org',
url='http://xapek.org',
scripts=[
- "bin/ebus_dump".
- "bin/ebus_app",
- "bin/ebus_web",
+ "bin/ebus_dump.py",
+ "bin/ebus_app.py",
+ "bin/web_prod.py",
+ "bin/web_dev.py",
],
packages=find_packages(),
package_data={'doc':['*.txt'], 'xml':['*.xml']},
@@ -34,8 +30,9 @@ setup(
"Intended Audience :: Developers",
],
requires=[
- "itty==0.6.7",
+ "bottle",
"SQLAlchemy",
+ "psycopg2",
],
)