summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorEbus-at-dockstar <ebus@dockstar>2013-03-25 10:24:28 +0100
committerEbus-at-dockstar <ebus@dockstar>2013-03-25 10:24:43 +0100
commit862282ce99760832d3e9e5b4b1171b861105e004 (patch)
tree0e229418e391917b79d42a8bdee46fb7a8612895 /setup.py
parent9522cdffa94f278eb5e1894600535986e22c2890 (diff)
downloadebus-alt-862282ce99760832d3e9e5b4b1171b861105e004.tar.gz
ebus-alt-862282ce99760832d3e9e5b4b1171b861105e004.zip
move old stuff away
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py38
1 files changed, 0 insertions, 38 deletions
diff --git a/setup.py b/setup.py
deleted file mode 100644
index aa607ed..0000000
--- a/setup.py
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/usr/bin/env python
-import subprocess
-from setuptools import setup, find_packages
-
-
-version = subprocess.Popen(["git", "describe", "--tags", "--long"],stdout=subprocess.PIPE).communicate()[0].strip()
-assert len(version) > 3
-
-
-setup(
- name='ebus',
- version=version,
- description='Ebus over TCP Library',
- author='xapek.org',
- author_email='ebus@xapek.org',
- url='http://xapek.org',
- scripts=[
- "bin/ebus_dump.py",
- "bin/ebus_app.py",
- "bin/web_prod.py",
- "bin/web_dev.py",
- ],
- packages=find_packages(),
- package_data={'doc':['*.txt'], 'xml':['*.xml']},
- include_package_data = True,
- long_description="""ebus library""",
- classifiers=[
- "Programming Language :: Python",
- "Topic :: Software Development :: Libraries :: Python Modules",
- "Intended Audience :: Developers",
- ],
- requires=[
- "bottle",
- "SQLAlchemy",
- "psycopg2",
- ],
- )
-