summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authoryvesf <yvesf@d0e8fea9-7529-0410-93fb-d39fd5b9c1dd>2010-04-10 10:53:59 +0000
committeryvesf <yvesf@d0e8fea9-7529-0410-93fb-d39fd5b9c1dd>2010-04-10 10:53:59 +0000
commitc5c54d4d6486d85a151c6fcd4c5dcdaf2dfbcaf6 (patch)
treec6206fc6fa56332feda8428a38858a8df48f9714 /setup.py
parentad031278c0e4a4108d5a56d99ddc7ce1030a80a0 (diff)
downloadebus-alt-c5c54d4d6486d85a151c6fcd4c5dcdaf2dfbcaf6.tar.gz
ebus-alt-c5c54d4d6486d85a151c6fcd4c5dcdaf2dfbcaf6.zip
include rev number in egg name
git-svn-id: http://10.2.2.13/svn/common/ebus@1640 d0e8fea9-7529-0410-93fb-d39fd5b9c1dd
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 11 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index ee95d97..ed47b66 100644
--- a/setup.py
+++ b/setup.py
@@ -1,10 +1,20 @@
#!/usr/bin/env python
+version='0.2'
+try:
+ import pysvn
+ from pysvn import Client
+ import os
+ extra = Client().info(os.path.dirname(__file__)).revision.number
+ version = "%s-r%s" % (version,extra)
+except:
+ pass
+
from setuptools import setup, find_packages
setup(
name='ebus',
- version='0.2',
+ version=version,
description='Ebus over TCP Library',
author='xapek.org',
author_email='ebus@xapek.org',