summaryrefslogtreecommitdiff
path: root/www/grafana2
diff options
context:
space:
mode:
authorCharlie Root <root@db.2.localnet.cc>2015-05-31 18:10:24 +0000
committerCharlie Root <root@db.2.localnet.cc>2015-05-31 18:16:01 +0000
commit05f23ccf40aa8d85a1811cbf9d6009f20cb0442e (patch)
tree1995e26f2a45e87014dec969d7e8479bbd2b3acb /www/grafana2
parent59b99ad6772969fa9168173bc6e1472e44326aa8 (diff)
downloadfreebsd-ports-grafana-master.tar.gz
freebsd-ports-grafana-master.zip
Update to 2.0.2 / b51a8f11d5HEADmaster
Diffstat (limited to 'www/grafana2')
-rw-r--r--www/grafana2/Makefile8
-rw-r--r--www/grafana2/distinfo4
-rw-r--r--www/grafana2/files/patch-package.json7
-rw-r--r--www/grafana2/files/patch-tasks_build__task.js10
-rw-r--r--www/grafana2/pkg-plist30
5 files changed, 36 insertions, 23 deletions
diff --git a/www/grafana2/Makefile b/www/grafana2/Makefile
index 56b9499..4ff7990 100644
--- a/www/grafana2/Makefile
+++ b/www/grafana2/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= grafana2
-PORTVERSION= 2.0.2
+PORTVERSION= 2.0.2.8f9eeb
CATEGORIES= www
MASTER_SITES= GITHUB:github
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}:github
@@ -20,8 +20,8 @@ USE_RC_SUBR= grafana2
USE_GITHUB= yes
GH_ACCOUNT= grafana
GH_PROJECT= grafana
-# b51a8f11d5 was master at 2015-05-02
-GH_COMMIT= b51a8f11d5
+# b51a8f11d5 was master at 2015-05-31
+GH_COMMIT= 8f9eeb5ebd
GH_TAGNAME= ${GH_COMMIT}
SUB_FILES= grafana2
@@ -63,7 +63,7 @@ do-build:
npm --cache ${WRKDIR}/npm-cache install && \
npm --cache ${WRKDIR}/npm-cache install grunt-cli && \
${ECHO_MSG} "Running grunt" && \
- node_modules/.bin/grunt
+ node_modules/.bin/grunt release
#do-install:
diff --git a/www/grafana2/distinfo b/www/grafana2/distinfo
index c0138a7..dded4e0 100644
--- a/www/grafana2/distinfo
+++ b/www/grafana2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (grafana2-2.0.2.tar.gz) = 775d448dbb766a586c53da761c306b7a0cc694b4ddcd059c393fe6b6f0231e9d
-SIZE (grafana2-2.0.2.tar.gz) = 18949096
+SHA256 (grafana2-2.0.2.8f9eeb.tar.gz) = 80d4560a78048cb0807c10556bb507d5d991e22f262ac5b42626b1a20732a7f7
+SIZE (grafana2-2.0.2.8f9eeb.tar.gz) = 19009051
diff --git a/www/grafana2/files/patch-package.json b/www/grafana2/files/patch-package.json
index dd1ba71..83de805 100644
--- a/www/grafana2/files/patch-package.json
+++ b/www/grafana2/files/patch-package.json
@@ -1,7 +1,4 @@
-karma-phantomjs-launcher depends on npmjs package 'phantomjs' which
-deliberately downloads big phantomjs binary that we don't need/want.
-
---- package.json.orig 2015-05-03 16:30:35 UTC
+--- package.json.orig 2015-05-29 06:22:46 UTC
+++ package.json
@@ -35,15 +35,6 @@
"grunt-usemin": "3.0.0",
@@ -12,7 +9,7 @@ deliberately downloads big phantomjs binary that we don't need/want.
- "karma-coverage": "0.3.1",
- "karma-coveralls": "0.1.5",
- "karma-expect": "~1.1.0",
-- "karma-mocha": "~0.1.4",
+- "karma-mocha": "~0.1.10",
- "karma-phantomjs-launcher": "0.1.4",
- "karma-requirejs": "0.2.2",
- "karma-script-launcher": "0.1.0",
diff --git a/www/grafana2/files/patch-tasks_build__task.js b/www/grafana2/files/patch-tasks_build__task.js
new file mode 100644
index 0000000..52a7581
--- /dev/null
+++ b/www/grafana2/files/patch-tasks_build__task.js
@@ -0,0 +1,10 @@
+--- tasks/build_task.js.orig 2015-05-31 16:02:12 UTC
++++ tasks/build_task.js
+@@ -6,7 +6,6 @@ module.exports = function(grunt) {
+ 'jshint:source',
+ 'jshint:tests',
+ 'jscs',
+- 'karma:test',
+ 'clean:on_start',
+ 'less:src',
+ 'concat:cssDark',
diff --git a/www/grafana2/pkg-plist b/www/grafana2/pkg-plist
index 218545b..0b8ab0c 100644
--- a/www/grafana2/pkg-plist
+++ b/www/grafana2/pkg-plist
@@ -28,9 +28,9 @@ bin/%%GO_PKGNAME%%
%%DATADIR%%/public/app/controllers/search.js
%%DATADIR%%/public/app/controllers/sidemenuCtrl.js
%%DATADIR%%/public/app/directives/all.js
+%%DATADIR%%/public/app/directives/annotationTooltip.js
%%DATADIR%%/public/app/directives/arrayJoin.js
%%DATADIR%%/public/app/directives/bodyClass.js
-%%DATADIR%%/public/app/directives/bootstrap-tagsinput.js
%%DATADIR%%/public/app/directives/configModal.js
%%DATADIR%%/public/app/directives/confirmClick.js
%%DATADIR%%/public/app/directives/dashEditLink.js
@@ -39,11 +39,12 @@ bin/%%GO_PKGNAME%%
%%DATADIR%%/public/app/directives/giveFocus.js
%%DATADIR%%/public/app/directives/grafanaSimplePanel.js
%%DATADIR%%/public/app/directives/grafanaVersionCheck.js
-%%DATADIR%%/public/app/directives/graphiteSegment.js
+%%DATADIR%%/public/app/directives/metric.segment.js
+%%DATADIR%%/public/app/directives/misc.js
%%DATADIR%%/public/app/directives/ngBlur.js
%%DATADIR%%/public/app/directives/ngModelOnBlur.js
%%DATADIR%%/public/app/directives/spectrumPicker.js
-%%DATADIR%%/public/app/directives/tip.js
+%%DATADIR%%/public/app/directives/tags.js
%%DATADIR%%/public/app/directives/topnav.js
%%DATADIR%%/public/app/directives/variableValueSelect.js
%%DATADIR%%/public/app/features/admin/adminEditUserCtrl.js
@@ -61,6 +62,7 @@ bin/%%GO_PKGNAME%%
%%DATADIR%%/public/app/features/annotations/partials/editor.html
%%DATADIR%%/public/app/features/dashboard/all.js
%%DATADIR%%/public/app/features/dashboard/dashboardCtrl.js
+%%DATADIR%%/public/app/features/dashboard/dashboardLoaderSrv.js
%%DATADIR%%/public/app/features/dashboard/dashboardNavCtrl.js
%%DATADIR%%/public/app/features/dashboard/dashboardSrv.js
%%DATADIR%%/public/app/features/dashboard/directives/dashSearchView.js
@@ -71,7 +73,9 @@ bin/%%GO_PKGNAME%%
%%DATADIR%%/public/app/features/dashboard/partials/dashboardTopNav.html
%%DATADIR%%/public/app/features/dashboard/partials/graphiteImport.html
%%DATADIR%%/public/app/features/dashboard/partials/import.html
+%%DATADIR%%/public/app/features/dashboard/partials/linksEditor.html
%%DATADIR%%/public/app/features/dashboard/partials/saveDashboardAs.html
+%%DATADIR%%/public/app/features/dashboard/partials/settings.html
%%DATADIR%%/public/app/features/dashboard/partials/shareModal.html
%%DATADIR%%/public/app/features/dashboard/partials/snapshotTopNav.html
%%DATADIR%%/public/app/features/dashboard/partials/variableValueSelect.html
@@ -86,6 +90,8 @@ bin/%%GO_PKGNAME%%
%%DATADIR%%/public/app/features/dashboard/timeSrv.js
%%DATADIR%%/public/app/features/dashboard/unsavedChangesSrv.js
%%DATADIR%%/public/app/features/dashboard/viewStateSrv.js
+%%DATADIR%%/public/app/features/dashlinks/editor.html
+%%DATADIR%%/public/app/features/dashlinks/module.js
%%DATADIR%%/public/app/features/org/all.js
%%DATADIR%%/public/app/features/org/datasourceEditCtrl.js
%%DATADIR%%/public/app/features/org/datasourcesCtrl.js
@@ -110,14 +116,15 @@ bin/%%GO_PKGNAME%%
%%DATADIR%%/public/app/features/panel/partials/panelTime.html
%%DATADIR%%/public/app/features/panel/partials/soloPanel.html
%%DATADIR%%/public/app/features/panel/soloPanelCtrl.js
-%%DATADIR%%/public/app/features/panellinkeditor/linkSrv.js
-%%DATADIR%%/public/app/features/panellinkeditor/module.html
-%%DATADIR%%/public/app/features/panellinkeditor/module.js
+%%DATADIR%%/public/app/features/panellinks/linkSrv.js
+%%DATADIR%%/public/app/features/panellinks/module.html
+%%DATADIR%%/public/app/features/panellinks/module.js
%%DATADIR%%/public/app/features/profile/changePasswordCtrl.js
%%DATADIR%%/public/app/features/profile/partials/password.html
%%DATADIR%%/public/app/features/profile/partials/profile.html
%%DATADIR%%/public/app/features/profile/profileCtrl.js
%%DATADIR%%/public/app/features/templating/editorCtrl.js
+%%DATADIR%%/public/app/features/templating/partials/editor.html
%%DATADIR%%/public/app/features/templating/templateSrv.js
%%DATADIR%%/public/app/features/templating/templateValuesSrv.js
%%DATADIR%%/public/app/filters/all.js
@@ -145,9 +152,9 @@ bin/%%GO_PKGNAME%%
%%DATADIR%%/public/app/panels/timepicker/editor.html
%%DATADIR%%/public/app/panels/timepicker/module.html
%%DATADIR%%/public/app/panels/timepicker/module.js
+%%DATADIR%%/public/app/partials/colorpicker.html
%%DATADIR%%/public/app/partials/confirm_modal.html
%%DATADIR%%/public/app/partials/dashboard.html
-%%DATADIR%%/public/app/partials/dasheditor.html
%%DATADIR%%/public/app/partials/edit_json.html
%%DATADIR%%/public/app/partials/error.html
%%DATADIR%%/public/app/partials/help_modal.html
@@ -161,7 +168,6 @@ bin/%%GO_PKGNAME%%
%%DATADIR%%/public/app/partials/search.html
%%DATADIR%%/public/app/partials/sidemenu.html
%%DATADIR%%/public/app/partials/submenu.html
-%%DATADIR%%/public/app/partials/templating_editor.html
%%DATADIR%%/public/app/partials/unsaved-changes.html
%%DATADIR%%/public/app/plugins/datasource/elasticsearch/datasource.js
%%DATADIR%%/public/app/plugins/datasource/elasticsearch/partials/annotations.editor.html
@@ -252,11 +258,9 @@ bin/%%GO_PKGNAME%%
%%DATADIR%%/public/css/less/variables.dark.less
%%DATADIR%%/public/css/less/variables.light.less
%%DATADIR%%/public/dashboards/default.json
-%%DATADIR%%/public/dashboards/empty.json
%%DATADIR%%/public/dashboards/home.json
%%DATADIR%%/public/dashboards/scripted.js
%%DATADIR%%/public/dashboards/scripted_async.js
-%%DATADIR%%/public/dashboards/scripted_gen_and_save.js
%%DATADIR%%/public/dashboards/scripted_templated.js
%%DATADIR%%/public/dashboards/template_vars.json
%%DATADIR%%/public/fonts/FontAwesome.otf
@@ -302,7 +306,9 @@ bin/%%GO_PKGNAME%%
%%DATADIR%%/public/test/specs/influx09-querybuilder-specs.js
%%DATADIR%%/public/test/specs/influxQueryBuilder-specs.js
%%DATADIR%%/public/test/specs/influxSeries-specs.js
+%%DATADIR%%/public/test/specs/influxSeries08-specs.js
%%DATADIR%%/public/test/specs/influxdb-datasource-specs.js
+%%DATADIR%%/public/test/specs/influxdbQueryCtrl-specs.js
%%DATADIR%%/public/test/specs/kbn-format-specs.js
%%DATADIR%%/public/test/specs/lexer-specs.js
%%DATADIR%%/public/test/specs/overview-ctrl-specs.js
@@ -310,7 +316,7 @@ bin/%%GO_PKGNAME%%
%%DATADIR%%/public/test/specs/row-ctrl-specs.js
%%DATADIR%%/public/test/specs/seriesOverridesCtrl-specs.js
%%DATADIR%%/public/test/specs/shareModalCtrl-specs.js
-%%DATADIR%%/public/test/specs/soloPanelCtrl-specs.js
+%%DATADIR%%/public/test/specs/singlestat-specs.js
%%DATADIR%%/public/test/specs/templateSrv-specs.js
%%DATADIR%%/public/test/specs/templateValuesSrv-specs.js
%%DATADIR%%/public/test/specs/timeSeries-specs.js
@@ -366,7 +372,7 @@ bin/%%GO_PKGNAME%%
%%DATADIR%%/public/vendor/css/spectrum.css
%%DATADIR%%/public/vendor/css/timepicker.css
%%DATADIR%%/public/vendor/filesaver.js
-%%DATADIR%%/public/vendor/jquery/jquery-2.1.1.min.js
+%%DATADIR%%/public/vendor/jquery/jquery-2.1.3.js
%%DATADIR%%/public/vendor/jquery/jquery.flot.crosshair.js
%%DATADIR%%/public/vendor/jquery/jquery.flot.events.js
%%DATADIR%%/public/vendor/jquery/jquery.flot.fillbelow.js