summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorYves Fischer <yvesf-git@xapek.org>2015-11-22 00:25:56 +0100
committerYves Fischer <yvesf-git@xapek.org>2015-11-22 00:25:56 +0100
commit6080b38fb2b6b3c1017bdd34bb7552bc7e26a4a0 (patch)
tree07b69c3c6a665ef290591e184ca0d2ba3b73fe01 /setup.py
parent49ac3c20cb77b90493ce79b4e31cf0f58cba0116 (diff)
downloadwatchnews-6080b38fb2b6b3c1017bdd34bb7552bc7e26a4a0.tar.gz
watchnews-6080b38fb2b6b3c1017bdd34bb7552bc7e26a4a0.zip
project restructure
make it a proper python package
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 18 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..f34922b
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,18 @@
+#!/usr/bin/env python3
+
+from distutils.core import setup
+
+setup(name='watchnews',
+ version='0.0.1',
+ description='RSS Feed watcher tools',
+ author='Yves Fischer',
+ author_email='yvesf+watchnews@xapek.org',
+ url='https://www.xapek.org/git/yvesf/watchnews',
+ packages=['watchnews'],
+ scripts=['watchnews-cli'],
+ depends=['peewee==2.7.1',
+ 'feedparser>=5.1.0',
+ 'newspaper3k==0.1.5',
+ 'Flask==0.10.1',
+ 'll-xist==5.13']
+ )