summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 18 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..f34922b
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,18 @@
+#!/usr/bin/env python3
+
+from distutils.core import setup
+
+setup(name='watchnews',
+ version='0.0.1',
+ description='RSS Feed watcher tools',
+ author='Yves Fischer',
+ author_email='yvesf+watchnews@xapek.org',
+ url='https://www.xapek.org/git/yvesf/watchnews',
+ packages=['watchnews'],
+ scripts=['watchnews-cli'],
+ depends=['peewee==2.7.1',
+ 'feedparser>=5.1.0',
+ 'newspaper3k==0.1.5',
+ 'Flask==0.10.1',
+ 'll-xist==5.13']
+ )